Skip to content

GL.iNet app

GL.iNet app requires router firmware version 3.100 and above. Please upgrade.

Click the Setup menu, choose your model.

setup menu

Then click the Upgrade on the left side.

leftside upgrade

Some models don't have V3.100 release firmware yet, please try testing(pre-release) firmware. Please find the download info at Firmware Release page.